Question Patch Viewer Broken???

Lucifer

Moderator
Staff member
Messages
821
Points
453
Hello everybody on ccm I was just quite curious on what this is

I have found a waw patch to fit my needs and work in the game mode war but the thing is the color of the points that pop up when you get a kill are blue so me and @dorathekiller97 tried to fix and we get this message when we start waw "Trying to set index 0 (which is a byte value) to invalid value 3415"
it does this when you even edit a say function to say something different could the screenshot be the problem that is why we get this error or is there a fix to this?
 
S

SeriousHD-

Guest
Hello everybody on ccm I was just quite curious on what this is

I have found a waw patch to fit my needs and work in the game mode war but the thing is the color of the points that pop up when you get a kill are blue so me and @dorathekiller97 tried to fix and we get this message when we start waw "Trying to set index 0 (which is a byte value) to invalid value 3415"
it does this when you even edit a say function to say something different could the screenshot be the problem that is why we get this error or is there a fix to this?
Well that is a normal ascii value, it is 0x12, so that isnt the problem. It is most likely a bug with some variable somewhere using OP_GetByte when it should be using OP_GetShort. When you see stuff like that in ascii it is just np++ trying to visualize a character with an undefined appearance, because DeviceControl2 is normally a hotkey for the console or a special system character. He probably used it for the button codes, because treyarch use that range for button keys (found that out with my ofw modding a while ago).
 

Lucifer

Moderator
Staff member
Messages
821
Points
453
Well that is a normal ascii value, it is 0x12, so that isnt the problem. It is most likely a bug with some variable somewhere using OP_GetByte when it should be using OP_GetShort. When you see stuff like that in ascii it is just np++ trying to visualize a character with an undefined appearance, because DeviceControl2 is normally a hotkey for the console or a special system character. He probably used it for the button codes, because treyarch use that range for button keys (found that out with my ofw modding a while ago).
Thank you Serious Do you have a idea on what the problem could be then?
 
S

SeriousHD-

Guest
Thank you Serious Do you have a idea on what the problem could be then?
No idea. Would have to do debugging on the script. Id start by looking for the value in the script. that value as a string is (0xD)W, so if that pops up anywhere that might also have todo with it
 

Top